Worked after importing old project?!

Bloodborne
Member
Registered: 2014-08-17
Posts: 22

Topic

Hi,

I just imported an old project that had RTS and just saw the brushes work! Is there any catch?

Thanks

Lea Hayes
Rotorz Limited
From: United Kingdom
Registered: 2014-03-04
Posts: 638

Response 1

Without further information it's hard to say.

Q1. Which version of Unity was the project previously used in?
Q2. Which version of Unity is the project now being used in?
Q3. Which version of RTS did the project previously use?
Q4. Which version of RTS does the project now use?

Bloodborne
Member
Registered: 2014-08-17
Posts: 22

Response 2

I'll get to you tomorrow on the question on what Unity version it was initially (older than 5.6, probably 5.3), silly me asking that without providing more info but current version is 2017.1 and RTS was I think latest, 2.4.0 IIRC. I didn't change RTS, I just opened my old project in 2017.1 accidentally, said it needed to upgrade the API, I said yes and wanted to show my friend how RTS doesn't work anymore and I could draw tiles! Finally I was keeping telling him that it's no good and it was there working! :D

Also, until you open source RTS and people find fixes to make it work in recent Unity versions, what solution do you suggest to make levels for my game? I searched for other assets but doesn't even come close. There is old Tiled that seems more matured but I can't stand the UI.

P.S. I REALLY wished you didn't stop developing this. I even taught people using it.

Lea Hayes
Rotorz Limited
From: United Kingdom
Registered: 2014-03-04
Posts: 638

Response 3

There are no known issues with RTS in Unity 5.5 but there are definitely issues in Unity 5.6 and Unity 2017.

Bloodborne wrote:

Also, until you open source RTS and people find fixes to make it work in recent Unity versions, what solution do you suggest to make levels for my game? I searched for other assets but doesn't even come close. There is old Tiled that seems more matured but I can't stand the UI.

RTS only stopped working in recent releases of Unity due to changes that were made in Unity itself. So if you want to continue to use RTS at the moment then I would suggest that you continue to use a lower version of Unity. Unity still produce patches for Unity 5.3.8, 5.4.5 and 5.5.4: https://unity3d.com/unity/qa/patch-releases

Bloodborne wrote:

P.S. I REALLY wished you didn't stop developing this. I even taught people using it.

I wish that the asset was making money when it was on sale on the asset store; but unfortunately it wasn't sustainable.

The asset will be released as open source soon with fixes for Unity 5.6 and eventually 2017. I'm considering adding a Patreon or something like that to the project.